Un problema típico que se produce al instalar el .Net Framework y el IIS tiene que ver con el orden en el que se instalan.

Parece ser que si tenemos instalado el .Net Framework y posteriormente instalamos IIS, nos encontraremos el siguiente error al intentar abrir aplicaciones ASP.NET desde Visual Studio:

Visual Studio .Net has detected that the web server is not running ASP.Net version 1.1. You will be unable to run ASP.Net web applications or services.

Aparentemente este error indica que la versión de ASP.NET no está registrada, aunque sí hayamos completado la instalación correctamente. Lo primero que se nos ocurre es reinstalar, pero hay una solución más eficiente.

En la carpeta C:WINDOWSMicrosoft.NETFrameworkv1.0.4322 tendremos que ejecutar el siguiente archivo con los parámetros indicados: aspnet_regiis.exe -i para corregir el problema.

De este modo, la última versión del .Net Framework que tengamos quedará registrada reemplazando a lo anterior (para ello es necesario indicar el parámetro -i).

Por supuesto, este método también serviría para instalar versiones posteriores del .Net Framework en caso de que aparezcan, evitando así instalar todo el paquete del programa.


Fatal error: Cannot use object of type stdClass as array in /homepages/35/d378790237/htdocs/davidsite.com/wp-content/plugins/social-counters/counters/facebook.php on line 56